Topic: Installing

claytonchatham on May 26, 2010, 11:46:20 AM

claytonchatham

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Don't mean to post a dumb question.

But I'm new to linux and need to know how to isntall this game.
Just downloaded it and I'm running the newest version of Ubuntu.

Any help would be appreciated.
Logged
  • Read 2664 times
  • Category General
Comments: 5

Lastmerlin on May 26, 2010, 12:07:37 PM
Reply #1

Lastmerlin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 463
  • Karma: +5/-0
    • View Profile
Quote from: 'claytonchatham' pid='277' dateline='1274870780'

Any help would be appreciated.

Download the source package for linux.
Have a look at the file INSTALL located in the top directory and follow the instructions. All required libraries except raknet may be installed with this command:

Code: [Select]
sudo apt-get install libogre-dev libois-dev libcegui-mk2-dev libceguiogre-dev libalut-dev liblua5.1-0-dev libvorbis-dev libvorbisfile3 g++
Logged

claytonchatham on June 10, 2010, 05:47:44 AM
Reply #2

claytonchatham

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Had major problems, now running Fedora 13. and get this message now
No package 'lua5.1' found
when i go to yum install liblua* it says its already installed.  Has anyone encountered this error before?
Logged

Lastmerlin on June 10, 2010, 07:44:19 AM
Reply #3

Lastmerlin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 463
  • Karma: +5/-0
    • View Profile
First idea: Switch build system: If you used cmake, try configure and vice versa.

Second idea: Go to /usr/lib/pkgconfig and make a symlink lua5.1.pc -> lua.pc (this might be lua5.pc or something similiar)

And please check, that you have lua5.1:
Code: [Select]

lua -v
Logged

claytonchatham on June 10, 2010, 08:55:29 AM
Reply #4

claytonchatham

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Ok, tried doing abit of what you said and it's not saying anything about lua5.1
but its now coming up with a new problem.

[root@localhost sumwars]# ./configure PKG_CONFIG=/usr/lib/pkgconfig/
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking pkg-config is at least version 0.9.0... ./configure: line 2345: /usr/lib/pkgconfig/: is a directory
no
checking for DEPS... configure: error: The pkg-config script could not be found or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

Alternatively, you may set the environment variables DEPS_CFLAGS
and DEPS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To get pkg-config, see .
See `config.log' for more details.

Thats one problem. Then if I change the pkgconfig path in the sumwars folder to min ver 0.25.0 then it says that the dependencies versions like OGRE arent a suitable version.
Not sure if that make a difference or not.
Logged

Lastmerlin on June 10, 2010, 03:26:22 PM
Reply #5

Lastmerlin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 463
  • Karma: +5/-0
    • View Profile
No, I did not mean, to pass this directory as a parameter to configure. The problem is, that lua5.1 is not found. There are two possible reasons:
1. Its not there
2. It has a different name (known to happen)

In case 1 you have to install it from an rpm or from source, because yum seems to be incapable to do this for your system. More probable is case 2: The name is lua5 or just lua on your system.
Try to find out with this command:
pkg-config --modversion lua
Also try lua5 . The pkg-config system uses some .pc files. So have a look into this folder /usr/lib/pkgconfig and search for the .pc file (its likely to be named lua.pc or lua5.pc). Set a symlink to this file name lua5.1.pc. Try again (with just configure, no additional parameters).
Logged