Topic: Problem with animation when entering Joringsbridge

Akien on June 18, 2014, 11:03:55 PM
Reply #45

Akien

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
@Akien: I have edited CMakeList.txt as you have advised, but errors still persist. Here is my output after editing file, "ldconfig", "make clean", "make":
http://pastebin.com/wMJtKEyv
It seems to have worked, the libCEGUIBase-0.so was found. Now the issue seems to be with libCEGUIOgreRenderer-0.so, so you could fix it the same way with:
Code: [Select]
TARGET_LINK_LIBRARIES(sumwars ${LINK_LIBS} /usr/local/lib64/libCEGUIBase-0.so /usr/local/lib64/libCEGUIOgreRenderer-0.so )
It looks like the linker doesn't find libs in /usr/local/lib by itself, I don't know if it's a Fedora-specific issue or related to Sumwars' buildsystem, I'll have to investigate.

Just for the record, could you give me the output of your /etc/ld.so.conf file?
Logged

Mike on June 19, 2014, 04:58:38 AM
Reply #46

Mike

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
@dezGusty: I have performed the following. In CMake-gui "File / Delete Cache", then "Configure" and "Generate". Then in Terminal ran "make". Same set of errors.
@Akien: Added this pat and now the "make" result is http://pastebin.com/iZEp9Aav
Looks like there is no errors. What's next? If everything is ready for installing, how can I perform installation and run SumWars after that?
Logged

Akien on June 19, 2014, 06:55:46 AM
Reply #47

Akien

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
@Akien: Added this pat and now the "make" result is http://pastebin.com/iZEp9Aav
Looks like there is no errors. What's next? If everything is ready for installing, how can I perform installation and run SumWars after that?
Well done! Now you should be all set for a "sudo make install", which should put the sumwars binary in /usr/local/bin and the data (textures, music, etc.) in /usr/local/share/sumwars. Afterwards typing "sumwars" in a terminal should start the game :-)
Logged

Mike on June 19, 2014, 04:44:51 PM
Reply #48

Mike

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Installation complete.
Now sumwars does not launch. Neither from shortcut in GNOME 3, nor from Terminal prompt.
Terminal returns the following:
[mike@localhost build]$ sumwars
sumwars: error while loading shared libraries: libCEGUIBase-0.so.3: cannot open shared object file: No such file or directory
[mike@localhost build]$

Should I add this file path to CMakeList.txt and rebuild? It is located at the same directory as libCEGUIBase-0.so.
Should I uninstall "Summoning Wars" previously installed as repository application?

Edit: I have removed repository (0.5.6) sumwars (it was about 120 MB), then run "sudo make install" again". Installation finishes too fast for a 120 MB application - just about 2-3 seconds. Something is wrong probably.

Edit: I have discovered my /etc/ld.so.conf contains a single string "include ld.so.conf.d/*.conf". Following this path I have found a set of *.conf files. None of them contained a path to /usr/local/lib64. So. I have added my own MyLibs.conf file with "/usr/local/lib64" and run "sudo ldconfig". Now previous error gone, but I have another message on "sumwars":
Segmentation error (core dumped)
I'm not sure whether "Segmentation error" is a correct translation, but "LC_ALL=C sumwars" has ignored to switch to English locale and output was in my locale language.
Now I have removed /etc/ld.so.conf.d/MyLibs.conf and run "sudo ldconfig /usr/local/lib64", "sudo ldconfig", "sumwars". Now I'm back at "sumwars: error while loading shared libraries: libCEGUIBase-0.so.3: cannot open shared object file: No such file or directory".
I'm still afraid that "sudo make install" finished in 2 seconds is a bad sign.
« Last Edit: June 19, 2014, 07:18:46 PM by Mike »
Logged

vyguera on June 19, 2014, 09:09:25 PM
Reply #49

vyguera

  • Newbie
  • *
  • Posts: 18
  • Karma: +2/-0
    • View Profile
Installation complete.
Now sumwars does not launch. Neither from shortcut in GNOME 3, nor from Terminal prompt.
Terminal returns the following:
[mike@localhost build]$ sumwars
sumwars: error while loading shared libraries: libCEGUIBase-0.so.3: cannot open shared object file: No such file or directory
[mike@localhost build]$


I had this error some time ago when I compiled sumwars for the first time to work with CEGUI 0.8.3.

My own problem was I had CEGUI 0.7 and 0.8.3 installed on my computer. I had to completelly uninstall CEGUI 0.7 from Synaptic (including all configuration files) and recompile & install CEGUI first and sumwars then. Also being aware to use my /usr/local/.../CEGUI instead of /usr/.../CEGUI paths in all CEGUI/make variables when configuring sumwars from cmake, as CEGUI 0.8.3 was installed on that particular path (/usr/local).

Hope this helps you.
P.S: Are you trying with CEGUI 0.8 or 0.8.3?

Edit: I also had to remove all my cfg files from my ~/.sumwars directory to be automatically rebuilt.
« Last Edit: June 19, 2014, 09:25:34 PM by vyguera »
Logged

Mike on June 19, 2014, 09:37:17 PM
Reply #50

Mike

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
@Vyguerra: Thank you for participation!
I have opened my YumEx (it's an alias for Synaptic in Fedora) in order to locate CEGUI entries. There are a couple dozens installed packages named like "cegui-devel 0.7.9-5.fc20", "cegui06 0.6.2-15.fc20" and so on. There is also "SILLY 0.1.0-16.fc20" among them (no idea why it was displayed as a result of "cegui" search query, but the fact is). Do you think there is a reason to uninstall all previous "cegui" instances before I can use CEGUI 0.8.3? Can you, please, give a hint what does "including all configuration files" mean?
Logged

vyguera on June 19, 2014, 10:12:14 PM
Reply #51

vyguera

  • Newbie
  • *
  • Posts: 18
  • Karma: +2/-0
    • View Profile
Hi Mike.

When I search for cegui in Synaptic Silly entry is also there. On the other hand I've never had it installed (so it is not a dependency for sumwars). Don't worry about it.

I personally uninstalled previous CEGUI versions because I was certain sumwars was trying to use cegui 0.7 instead of cegui 0.8.3 and in my case no other packages had cegui as a dependency than sumwars so I didn't mind to uninstall all them.

Nevertheless if you prefer to leave previous cegui packages installed you can ensure first if you are using /usr/local paths in all you cmake properties for CEGUI. I have attached you a screenshot. If this doesn't work you should consider uninstall them.

Furthermore, when I open Synaptic, if I right click on an installed package, I can check it to be (just) unistalled or completely uninstall (what removes all config files in /etc or wherever). I mean you should use this second option (if it's available for you).

Regards.
Logged

Mike on June 21, 2014, 10:12:12 AM
Reply #52

Mike

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
I have removed "cegui" packages via YumEx. Now starting "sumwars" returns another error:
[mike@localhost build]$ sumwars
sumwars: error while loading shared libraries: libCEGUIBase-0.7.9.so: cannot open shared object file: No such file or directory
[mike@localhost build]$

Aha! Now sumwars requires different dependencies. I have rebuilt and reinstalled CEGUI. Then rebuilt and reinstalled Sumwars. Here is an output of CMake-gui after configuring/generating Sumwars:
http://pastebin.com/PNLfnuJ5

Starting "sumwars" in Terminal now gives an output:
[mike@localhost build]$ sumwars
sumwars: error while loading shared libraries: libCEGUIBase-0.so.3: cannot open shared object file: No such file or directory
[mike@localhost build]$


I have tried to run an executable file from /build folder via Terminal ang got the following output:
http://pastebin.com/DWKgBfgH

Maybe there is any hint here?

Edit: I have found a similar issue here: http://www.ogre3d.org/forums/viewtopic.php?f=2&t=78729
Maybe I need this "parser" as well? The problem is I have no idea how to set it up.
« Last Edit: June 21, 2014, 02:47:14 PM by Mike »
Logged

Akien on June 21, 2014, 02:51:19 PM
Reply #53

Akien

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Quote from: Mike
Starting "sumwars" in Terminal now gives an output:
[mike@localhost build]$ sumwars
sumwars: error while loading shared libraries: libCEGUIBase-0.so.3: cannot open shared object file: No such file or directory
[mike@localhost build]$


I have tried to run an executable file from /build folder via Terminal ang got the following output:
http://pastebin.com/DWKgBfgH

Maybe there is any hint here?

Now there definitely seems to be an issue with Sumwars searching for the CEGUI libs in /usr/lib64 even though they were detected in /usr/local/lib64 (and the sumwars executable was built and linked against the latter).
@fusion44: Any idea where this would come from? I moved my CEGUI libs to /usr/local/lib64 and the headers to /usr/local/include, they are correctly detected by the cmake module, so the suwmars executable can be built.
But then indeed, when launching the program, I get a segfault since it searches for the CEGUI lib in /usr/lib64: http://pastebin.com/1VbHnqik

@Mike: Thanks for your really complete reports. There seems to be an issue with Sumwars when CEGUI is located in the /usr/local prefix instead of /usr. If I were you, I start anew and build cegui with the /usr prefix.
* Remove all cegui packages that might be provided by Fedora already
* Build cegui 0.8.x with the /usr prefix (You would have to set (in cmake-gui, set "CMAKE_INSTALL_PREFIX" to "/usr" instead of "/usr/local")
* Run make install to install cegui in /usr/lib64 and /usr/include
* Build sumwars, it should detect the correct version of cegui automatically
* Run make install and play "sumwars" (maybe remove the ~/.sumwars directory too, to make sure the config is not broken because of your previous attempts).

Now that's just a workaround if you'd like to be able to play Sumwars now, after all those compilations woes you've been going through (it's the best way to learn though, that's exactly how I got the little knowledge I have).
In the end the sumwars code should be fixed so that it's possible to build and run sumwars again every supported version of cegui when it's installed in /usr/local.

You should also note that if you install cegui in the /usr prefix, you probably won't be able to install an official cegui package next to it, since some files might conflict with each other. If Fedora were to issue cegui 0.8.3 as an update or a backport to Fedora 20, I would advise you to use it preferentially.
Logged

Akien on June 21, 2014, 03:04:46 PM
Reply #54

Akien

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Logged

fusion44 on June 21, 2014, 04:06:23 PM
Reply #55

fusion44

  • Administrator
  • Sr. Member
  • *****
  • Posts: 459
  • Karma: +10/-0
    • View Profile
Hi Mike,

please try running "export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib" in command line before you start sumwars.
I suspect by installing multiple versions of CEGUI, you've got some left over configurations which are wrongly detected by cmake.
Logged

fusion44 on June 21, 2014, 04:09:20 PM
Reply #56

fusion44

  • Administrator
  • Sr. Member
  • *****
  • Posts: 459
  • Karma: +10/-0
    • View Profile
Oh, would you mind stopping by in IRC? It may be quicker to discuss this issue there.
Logged

Mike on June 21, 2014, 05:13:22 PM
Reply #57

Mike

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Thank you Akien. I've performed trying to rebuild from CEGUI. When configuring it I have a "red message for developers". Maybe that will help to discover something important: http://pastebin.com/XDpy8xcY

Now I have rebuilt and reinstalled CEGUI, returned CMakeList.txtx to default state, then rebuilt and reinstalled Sumwars. Deleted everything from /.sumwars.

And it has launched! That was the first positive result from the point I started from. Reworked splash screen and updated interface - that means we have an updated game. But...

The very first issue I noticed is when I tried to change game language to my native. It has lost all captures on menu items. Just empty buttons :( I had to delete everything from /.sumwars in order to reset settings.
But it was not very important as long as English settings were OK. I have created a character from scratch and ran to Joringsbridge. That was the second frustration, because animation behaviour was the same as in 0.5.6. I'm a bit upset. All those manipulations we all performed in order to launch a new version did not fix the bug.
The last hope is that I did not complete something important and did not load new maps or something else. Is this possible?

@Fusion44: Hi Fusion44. It has launched finally, but something is still wrong. Now some issues with game content I suppose.

Logged

fusion44 on June 22, 2014, 07:55:45 AM
Reply #58

fusion44

  • Administrator
  • Sr. Member
  • *****
  • Posts: 459
  • Karma: +10/-0
    • View Profile
Hi Mike,

glad to hear it finally worked (somewhat...). Can you send me your save file?
I'll take a look at it. Maybe I can reproduce it with your save game.
Logged

Mike on June 22, 2014, 08:38:42 AM
Reply #59

Mike

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Hello Fusion44.
Here is my save files. I have some achievements: it is possible to talk to certain NPCs at Joringsbridge location. All you need is to aim it and click. A character starts moving inside the animation, comes to NPC and can have a talk. But after finishing a conversation a character stays inside "animation" and is not able to just walk away. You need "ESC", "Save an quit" and load again in order to use a teleport stone or walk into nearby village (where quest with berries is to be performed).
Pay attention: in my case names of locations are displayed in non-friendly manner: aisNorthMeadow, medMercCamp, aisPlains etc..
Logged