Topic: Running into issues building sumwars on my Ubuntu 12.04 machine

SurpriseBoy on May 21, 2014, 10:29:17 PM

SurpriseBoy

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
I made a new folder called "build" in the source folder of sumwars 5.8 that I downloaded.
Using the terminal I entered the folder and then typed "cmake .."

Then I get this error...

-- Got release vorbis: /usr/lib/x86_64-linux-gnu/libvorbis.so
CMake Error at /usr/share/cmake-2.8/Modules/FindBoost.cmake:1202 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.46.1

  Boost include path: /usr/include

  The following Boost libraries could not be found:

          boost_chrono

  Some (but not all) of the required Boost libraries were found.  You may
  need to install these additional Boost libraries.  Alternatively, set
  BOOST_LIBRARYDIR to the directory containing Boost libraries or BOOST_ROOT
  to the location of Boost.
Call Stack (most recent call first):
  CMakeLists.txt:201 (find_package)


-- Configuring incomplete, errors occurred!


Please do help me out with this. I need to know what is happening. I intend on running Summoning Wars successfully from my machine and contributing to the project as much as I can, from a programming point of view.
Logged
  • Read 1244 times
  • Category General
Comments: 2

SurpriseBoy on May 21, 2014, 10:55:53 PM
Reply #1

SurpriseBoy

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
I installed the required boost libraries from synaptic package manager. But it seemed that a lot of other boost libraries were wiped out of my machine to install the new ones. Now the "cmake .." command gives the following errors.

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Boost_DATE_TIME_LIBRARY (ADVANCED)
    linked by target "sumwars" in directory /home/shaan/Desktop/sumwars/sumwars-0.5.8
Boost_FILESYSTEM_LIBRARY (ADVANCED)
    linked by target "sumwars" in directory /home/shaan/Desktop/sumwars/sumwars-0.5.8
Boost_SYSTEM_LIBRARY (ADVANCED)
    linked by target "sumwars" in directory /home/shaan/Desktop/sumwars/sumwars-0.5.8
Boost_THREAD_LIBRARY (ADVANCED)
    linked by target "sumwars" in directory /home/shaan/Desktop/sumwars/sumwars-0.5.8

-- Configuring incomplete, errors occurred!


And then there is another issue I have come upon. Previously I had built from source and installed CEGUI 0.8 And then I realized that I was supposed to install only CEGUI version 0.7 from the build instructions provided on the this website. So I deleted the folder CEGUI folder and binaries in the /usr/local/lib/ folder and then I built from source version 0.7. But even though I ran the command "cmake .." cmake detected CEGUI 0.8 not 0.7. Am I in trouble? I have issued the make command already to sumwars. Do let me know what you folks think thanks! :D


[A LITTLE WHILE LATER]

The CEGUI thing has resulted in the following error. Someone please help. xD

make[2]: *** No rule to make target `/usr/local/lib/libCEGUIBase-0.so', needed by `sumwars'.  Stop.
make[1]: *** [CMakeFiles/sumwars.dir/all] Error 2
make: *** [all] Error 2
shaan@shaan-K55VM:~/Desktop/sumwars/sumwars-0.5.8/build$
« Last Edit: May 21, 2014, 10:59:56 PM by SurpriseBoy »
Logged

fusion44 on May 23, 2014, 04:38:16 PM
Reply #2

fusion44

  • Administrator
  • Sr. Member
  • *****
  • Posts: 459
  • Karma: +10/-0
    • View Profile
Hey SurpriseBoy,

does this problem still persist or is it solved with the other problem in the help thread?

Thanks!
Logged