Topic: Kubuntu build from src --Error

agast2 on May 08, 2012, 06:58:22 PM

agast2

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Hello all,

right now i did try to go for building on Kubuntu 12 LTS.
And poww.. running into error.
After having followed the instructions on the page for
building-instructions, i get the following output:
Code: [Select]
-- Looking for POCO_NetSSL...
-- Found POCO_NetSSL: optimized;/usr/lib/libPocoNetSSL.so;debug;/usr/lib/libPocoNetSSLd.so
-- Looking for POCO_XML...
-- Found POCO_XML: optimized;/usr/lib/libPocoXML.so;debug;/usr/lib/libPocoXMLd.so
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
X11_Xrandr_INCLUDE_PATH (ADVANCED)
   used as include directory in directory /home/tuxator/Downloads/sumwars-0.5.6
X11_Xrandr_LIB (ADVANCED)
    linked by target "sumwars" in directory /home/tuxator/Downloads/sumwars-0.5.6

mmhhh... honestly??
I have no idea how to fix this.....
Can someone please help me here ?

thx in advance,
regards
agast2

EDIT: Ok, after reading on web-page about specific things
           to watch when using ubuntu, installing the extra
           libxrandr-dev, it concluded at last cmake, two
           messages given, but scroll to fast to get them.
           Make also pases, even sudo make install .
           But finally it crashes, when try to start the
           program.... Can someone help ? please ?
« Last Edit: May 08, 2012, 08:45:33 PM by agast2 »
Logged
  • Read 2385 times
  • Category Help
Comments: 3

protogenes on May 08, 2012, 08:57:41 PM
Reply #1

protogenes

  • Administrator
  • Jr. Member
  • *****
  • Posts: 59
  • Karma: +5/-0
    • View Profile
Hello again,

you are almost the ideal user, by reading the wiki and stuff :)
Okay it successfully compiled but crashes when run. We need the logfiles which are generated in ~/.sumwars/. Please attach them at the forum or upload them to dpaste.org or similar. Also I would like to see the CMake configuration you used to build the game (the mode and path values).
And you might join the IRC again for faster (and german) replies.
Logged

agast2 on May 08, 2012, 09:22:42 PM
Reply #2

agast2

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Hello protegenes,

first thing(logs) will be sure easy,

then i try to attach some screenshot's, which
i already made in advance, i did however in my first
attempt go for the shell version, precise after the given
command on web-page, until i found out about the Ubuntu
specific stuff....After that finishing make and make install
i did even reboot.

But no matter what, i do always get a Crash-report from the system.

Thnx for help,
best regards, agast2
Logged

Trilby on May 08, 2012, 10:35:57 PM
Reply #3

Trilby

  • Full Member
  • ***
  • Posts: 119
  • Karma: +0/-0
    • View Profile
I think I had a similar error judging by your logs. I had to manually edit the plugins.cfg within ~./sumwars

The "PluginFolder=" line had defaulted to NOTFOUND. So I adjusted this to match the path where my OGRE libs were. /usr/lib/OGRE or /usr/local/lib/OGRE/

I don't know if this will fix your issue, but you could check that.
« Last Edit: May 08, 2012, 10:54:34 PM by Trilby »
Logged