Topic: svn repository

DaveYY on August 09, 2010, 06:04:03 PM


  • Newbie
  • *
  • Posts: 18
  • Karma: +0/-0
    • View Profile
Hi. First of all thank you for your work.
I see it's still under development and but it is already really nice.

I downloaded the code via svn, I compiled and everything was fine.
Than after some "svn up" (from revision 1980 on) the code it's not compiling any more.
So my question is: are there particular revisions which I should expect to work or any revision should compile ?

Here the error I get in compilation:
make[1]: Entering directory `/home/Dati/pacchetti/games/sumwars'
make[1]: *** No rule to make target `src/core/clientnetwork.cpp', needed by `src/core/sumwars-clientnetwork.o'. Stop.
make[1]: Leaving directory `/home/Dati/pacchetti/games/sumwars'
make: *** [all] Error 2

I tried with 'make clean' and 'make distclean' too but nothing.

Best regards,

P.S.: I've created two users in the forum as the first (DaveXX) was not working. I never received the confirmation email, though I try to push the resend button more than one time. So you can erase the DaveXX user. Sorry for the inconvenience.
  • Read 1447 times
  • Category General
Comments: 1

Lastmerlin on August 09, 2010, 10:08:08 PM
Reply #1


  • Administrator
  • Sr. Member
  • *****
  • Posts: 463
  • Karma: +5/-0
    • View Profile
Thanks a lot for reporting the issue :)
The problems seems to be that we are switching to cmake system and therefore configure was not updated properly. I think I have fixed it. Get an update to revision >=2004 and try again. Alternatively, use the cmake system by starting
Code: [Select]
cmake .
instead of configure.