Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - dezGusty

Pages: 1 [2] 3 4 ... 17
16
Programming / Re: Support for CEGUI 0.8, Ogre 1.9
« on: January 20, 2014, 11:06:56 PM »
Test version.

For anyone interested, here's a nightly build of the gussound branch where cegui 0.8 support has been added. If another version will be uploaded later on, this link will no longer work.
https://drive.google.com/file/d/0Byx-8I_NSC6-YUxMT2JUY24xNHM/edit?usp=sharing

17
Programming / Re: Support for CEGUI 0.8, Ogre 1.9
« on: January 20, 2014, 10:03:17 PM »
Additional small fixes. Now the dwarvenfall battle should be playable. I discovered a rather specific bug:
if you play with a Priest and use the skill "bladestorm" next to a fire element, the game crashes when trying to connect an item to a bone of the fire element. (I'm going to guess there is no bone in the fire element).

18
Programming / Re: Support for CEGUI 0.8, Ogre 1.9
« on: January 19, 2014, 11:02:54 PM »
An additional set of fixes: now the dialogs should no longer have unusable entries. main menu buttons should also be fine .

19
Programming / Re: Support for CEGUI 0.8, Ogre 1.9
« on: January 19, 2014, 03:53:53 PM »
There's also an issue with the Tooltips: you don't get the default tooltip being displayed (E.g. the descriptions for the user attributes).
The custom tooltip used for inventory items is displayed though.

20
Programming / Re: Support for CEGUI 0.8, Ogre 1.9
« on: January 17, 2014, 07:35:52 AM »
Hi, I made some additional fixes. Most things should work properly now.

Known issues:
- only 1 main menu texture used for all chars in the char list (they all look the same in the button preview image)
- no minimap is rendered
- the story cannot be fully played, as it's sometimes not possible to interract with other chars (dialoguewindow not responding to clicks).
- sometimes, the game becomes very slow when viewing a vendor's / trader's items.

21
Programming / Re: Support for CEGUI 0.8, Ogre 1.9
« on: January 15, 2014, 11:28:00 PM »
1. Fixed the skill tree display.
2. Made the layout click-through enabled. You can walk around again now.

TODO:
1. Fix dialog window (crashes at dialog).
2. Test to see if there are other crash-causing issues
3. Update fonts.

22
Programming / Re: Support for CEGUI 0.8, Ogre 1.9
« on: January 15, 2014, 06:28:59 PM »
Well.. that did not help. But I did make progress on identifying the cause of the crashes. Still on the todo list:
1. Fix the skill tree display
2. Make the layouts click-through enabled (currently, you cannot walk around, as the clicks seem to stop at the UI) :-).
3. Test to see if there are other crash-causing issues
4. Update the fonts... they are a bit larger now by default.

23
Programming / Re: Support for CEGUI 0.8, Ogre 1.9
« on: January 14, 2014, 10:46:58 PM »
Hmm... I did not think about using the CEGUI version. Thanks :-). I'll give it a try.

24
Programming / Re: Support for CEGUI 0.8, Ogre 1.9
« on: January 13, 2014, 08:57:05 PM »
I'm using a 5.1 version. I think it's the official version that comes with luarocks.
And that seems to be linked to MSVCR80.dll

25
Programming / Re: Support for CEGUI 0.8, Ogre 1.9
« on: January 13, 2014, 11:38:16 AM »
Hey fusion.

It was more complex. I changed the way in which windows hold each-other and that broke a couple of callbacks from being triggered.
I reworked it more right now. There are still some issues (it will still crash if you want to open the inventory or skill tree), but it's almost usable :-).
However, I'm having issues with debugging, as when using the debug build, I get an exception thrown from lua. Up to now, I was typically working on the Release version, so I don't know whether this is a new issue.

Did you encounter any issues before when working with the Debug build and Lua?

Anyway, the entire UI is quite hacky right now, as we have the widget names written in code. I will want to try out a different approach at some point in the future :-)

26
Programming / Support for CEGUI 0.8, Ogre 1.9
« on: January 10, 2014, 09:07:05 PM »
Hi,

I made changes to the CEGUI resource files for the game throughout this week. The files should work now with CEGUI 0.8.
Unfortunately, I did not add support for the previous CEGUI release yet (so I only performed changes to support the CEGUI 0.8).

It's not ready yet. I cannot seem to get the 3D scene to be displayed, and I'm not sure as to whether this is a CEGUI issue or an OGRE issue. Anyway...

If you want to test the build, use the branch named "gussoundtest". Remember to also update the "resources.cfg" file to use the new folders for the CEGUI 0.8 resources (in the emotionsets, GUI and GUI_XML_schemas resource groups).

E.g.
Code: [Select]
[GUI]
FileSystem=.//./share/resources/gui_0.8/configs
FileSystem=.//./share/resources/gui_0.8/fonts
FileSystem=.//./share/resources/gui_0.8/fonts/${ASPECT_RATIO}
FileSystem=.//./share/resources/gui_0.8/imagesets
FileSystem=.//./share/resources/gui_0.8/layouts
FileSystem=.//./share/resources/gui_0.8/layouts/common
FileSystem=.//./share/resources/gui_0.8/layouts/${ASPECT_RATIO}
FileSystem=.//./share/resources/gui_0.8/looknfeel
FileSystem=.//./share/resources/gui_0.8/schemes
FileSystem=.//./share/resources/gui_0.8/animations

[GUI_XML_schemas]
FileSystem=.//./share/resources/gui_0.8/xml_schemas

[emotionsets]
FileSystem=.//./share/resources/emotionsets
FileSystem=.//./share/resources/gui_0.8/emotionsets

27
Programming / Re: World editor
« on: October 01, 2013, 07:08:09 PM »
Hi, I couldn't test this on a WinXP machine, but I recently encountered an issue while trying to run an executable built with VS2012 on a Windows XP SP3 machine.

The cause is described here:
http://blogs.msdn.com/b/vcblog/archive/2012/06/15/10320645.aspx

For the final release, it seems that we'll have to either add a VS2010 build or change the compatibility target for VS2012 (the latter seems easier).

EDIT: btw, in the "plugins.cfg" file that is distributed with the editor, you forgot the hard-coded path for "PluginFolder". (It should be "PluginFolder=". I think)

28
General / Re: Away until 25 September 2013
« on: September 12, 2013, 04:57:18 AM »
Ok then, have fun and come back all charged up :-)

29
General / Re: IRC Meeting Sunday
« on: September 06, 2013, 10:11:36 PM »
You mean: this sunday :)

30
Sound & Music / Re: I may be able to help with music
« on: September 06, 2013, 10:10:43 PM »
Sounds good  :D

Pages: 1 [2] 3 4 ... 17