Topic: .deb packages for 0.5.6 (Debian, Ubuntu, etc)

mafm on July 08, 2012, 12:09:57 AM

mafm

  • Newbie
  • *
  • Posts: 24
  • Karma: +2/-0
    • View Profile
Hi,

(I hope that this is the right forum, otherwise please move to the most convenient one).

I tried to get the package officially into Debian a few months ago (shortly after the release), but failed to be included initially because of multiple copies of tinyxml embedded in up to 3 directories [1], that I didn't detect and thus forgot to document its license, so the packages were rejected [2].  Actually, IIRC, it's me who implemented as an option in CMake to use the external tinyxml installed in the system instead of the internal library, but I failed to realise that there were other copies around in other dirs.

I was quite busy in the last few months (especially with OGRE packages that I also maintain in Debian and are pulled directly into Ubuntu; and then the same for SDL packages); and was a bit ashamed of having the package rejected again if something was wrong, so I didn't resubmit it again yet.  One has to go though some efforts and pull some strings to get the package accepted, because then Debian is the responsible for all what happens with the package (from licensing to maintainance to security problems during possibly several releases, etc).

Anyway, it's being worked on.  You can check here:

  http://www.ebi.ac.uk/~mafm/deb/sumwars/

  !!! Please, DON'T PUBLISH THE URL OUTSIDE THE FORUMS, I might remove the packages at any time and it's intended only for little audience of people interested in the game, like this forum !!!

You just need to download the 0.5.6 debs of both sumwars and sumwars-data, and install with "dpkg -i" after installing the following dependencies with apt-get or your favourite method:

  $ apt-cache depends sumwars
  sumwars
  Depends: libalut0
  Depends: libc6
  Depends: libcegui-mk2-0.7.6
  Depends: libenet1a
  Depends: libgcc1
  Depends: liblua5.1-0
  Depends: libogg0
  Depends: libogre-1.7.4
  Depends: libois-1.3.0
  Depends: libopenal1
  Depends: libphysfs1
  Depends: libstdc++6
  Depends: libtinyxml2.6.2
  Depends: libvorbis0a
  Depends: libvorbisfile3
  Depends: libx11-6
  Depends: libxrandr2
  Depends: sumwars-data
  Depends: ttf-dejavu-core

At this point I am not sure if the packages will work out of the box, although my locally installed package still works fine.  But maybe they don't work depending on your configuration, and it's not tested in Ubuntu or other Debian derivatives.

Cheers.


[1] $ find -iname tinyxml.h
./tools/graphicengine/tinyxml.h
./share/translation/xmlgettext/tinyxml.h
./src/tinyxml/tinyxml.h

[2] Embedded copies of external libraries is a big NO-NO, because if there's a security issue with tinyxml (or whatever library is being copied), the security team doesn't only have to patch the tinyxml package itself, but the multiple copies that other packages embed.  With ~15k source packages in the archive, even if only 1% use only 1 embedded library, that's 150 potential-problems being hatched -- so things get quickly out of hand, and thus the strictness.
Logged
  • Read 2697 times
  • Category General Discussion
Comments: 4

KroArtem on July 08, 2012, 09:02:07 PM
Reply #1

KroArtem

  • Full Member
  • ***
  • Posts: 104
  • Karma: +0/-0
    • View Profile
Any need to test it under ubuntu 12.04 x86-64? I can try under ubuntu 12.10 x86-64 but it has ogre 1.8 now.
Logged

mafm on July 09, 2012, 05:32:30 PM
Reply #2

mafm

  • Newbie
  • *
  • Posts: 24
  • Karma: +2/-0
    • View Profile
Any need to test it under ubuntu 12.04 x86-64? I can try under ubuntu 12.10 x86-64 but it has ogre 1.8 now.

You can try to test it, but it will only work with the 1.7 version I guess:

  https://launchpad.net/ubuntu/+source/ogre

Please report your findings here :)
Logged

KroArtem on July 10, 2012, 06:57:03 PM
Reply #3

KroArtem

  • Full Member
  • ***
  • Posts: 104
  • Karma: +0/-0
    • View Profile
Actually, they provide both 1.7.4 and 1.8 versions, you're right :)
Ok, I'll try soon.
Logged

KroArtem on July 13, 2012, 09:12:30 PM
Reply #4

KroArtem

  • Full Member
  • ***
  • Posts: 104
  • Karma: +0/-0
    • View Profile
Good evening, your debs don't work under ubuntu 12.10 alpha ( I think you remember we discussed it some times ago in irc)
Under ubuntu 12.04 sumwars-data installs correctly but sumwars_0.5.6-1-amd64.deb requires libcegui-mk2-0.7.6 but only version 0.7.5 is available from repository.
Logged